OpenWRT可以安装在物理机器上,虚拟机,也是中国体育彩票开奖环境。此帖子总结了一些步骤如何让OpenWRT运行到您的中国体育彩票开奖环境中。 

中国体育彩票开奖.图片:Sulinggg / OpenWrt:最新
//ift.tt/39lTyxE

拓扑


创建MacVlan网络


创建MacVlan配置:

创建MacVlan网络:

命令行:

docker network create -d macvlan --subnet=192.168.2.0/24 --gateway=192.168.2.1 -o parent=wlan0 macnet


检查为中国体育彩票开奖环境创建的网络:

[email protected]:/etc# docker network ls
NETWORK ID          NAME                DRIVER              SCOPE
0f5799ba3db3        bridge              bridge              local
ad41a2fa3a8a        host                host                local
af9991f302ea        macnet              macvlan             local
7a6c6991d92b        macvlan             null                local
74f1375fb8c1        none                null                local


拉映像并创建容器

来自Portainer:

其他配置:
网络 - 选择Macnet
重启政策 - 从不(用于测试)
运行&资源 - 特权模式启用

如果您有一个已运行的容器,您希望更改重启策略,您可以使用中国体育彩票开奖 Update命令更改:

中国体育彩票开奖.更新 - restart除非停止的container_id

docker pull sulinggg/openwrt:latest
docker run --restart always --name openwrt -d --network macnet --privileged sulinggg/openwrt:latest /sbin/init

部署底座后,检查从网络麦克网分配的IP地址。您需要手动将此IP设置为中国体育彩票开奖 / etc / config / network文件。 

bash-5.0# cd /etc/config
bash-5.0# nano network 
bash-5.0# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7d:334c:6108::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.96'
        option gateway '192.168.2.1'
        option dns '8.8.8.8'

config interface 'vpn0'
        option ifname 'tun0'
        option proto 'none'

bash-5.0# 

Now you should be able to access your OpenWRT web gui from http://192.168.2.96


笔记:

默认情况下,Ubuntu在端口53上有系统已解决。如果您想要运行自己的DNS服务器,则不能因为端口53已经在使用中,因此您将收到类似的错误:“侦听TCP 0.0.0.0:53:绑定:已使用的地址” 。

您已作为本地DNS服务器启用Systemd Displaved。您可以通过设置禁用它 dnsstublistener = no 在/etc/systemd/resolved.conf中,然后重新启动systemd解析服务。然后,它将在不绑定到端口53的情况下开始,允许DNSMASQ更换。

[解决]
DNS = 1.1.1.1.
#fallbackdns =
#domains =
#llmnr =否
#multicastdns = no
#dnssec = no
#dnsovertls =否
#缓存=否
dnsstublistener = no
#creadEtchosts =是的

来自Blogger. http://blog.fabiandinkins.com/2021/03/using-portainer-to-deploy-openwrt-docker.html

经过 Jon.

发表评论